summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-26 04:47:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 04:54:33 +0100
commitea3f45a5a0d9f55ca1df2c7f9d9fd45d624dd1a1 (patch)
treeebfcfe40a12c060317a83be1a3470365578dd056
parentf160557b955a27c681d4482e7b541966e31e3c78 (diff)
downloadguix-patches-ea3f45a5a0d9f55ca1df2c7f9d9fd45d624dd1a1.tar
guix-patches-ea3f45a5a0d9f55ca1df2c7f9d9fd45d624dd1a1.tar.gz
gnu: python2-pathlib2: Update to 2.3.0.
* gnu/packages/python.scm (python2-pathlib2): Update to 2.3.0. [propagated-inputs]: Add PYTHON2-SCANDIR.
-rw-r--r--gnu/packages/python.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 19f43dc27c..5b8c5081fc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8061,13 +8061,13 @@ anymore.")
(define-public python2-pathlib2
(package
(name "python2-pathlib2")
- (version "2.1.0")
+ (version "2.3.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "pathlib2" version))
(sha256
(base32
- "0p050msg5c8d0kadv702jnfshaxrb0il765cpkgnhn6mq5hakcyy"))))
+ "1cx5gs2v9j2vnzmcrbq5l8fq2mwrr1h6pyf1sjdji2w1bavm09fk"))))
(build-system python-build-system)
;; We only need the the Python 2 variant, since for Python 3 our minimum
;; version is 3.4 which already includes this package as part of the
@@ -8075,7 +8075,8 @@ anymore.")
(arguments
`(#:python ,python-2))
(propagated-inputs
- `(("python2-six" ,python2-six)))
+ `(("python2-scandir" ,python2-scandir)
+ ("python2-six" ,python2-six)))
(home-page "https://pypi.python.org/pypi/pathlib2/")
(synopsis "Object-oriented file system paths - backport of standard
pathlib module")