summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-05-03 17:10:22 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2017-05-04 13:47:23 +0200
commite8e1ace0394dd979a1ad5459ebb5b9247f7ff1d7 (patch)
treef8e68b07affbb8a259486c77a7a0a922a6bbddec
parentf4129cdd6a3c9ab01e16020dcd1c3708365bba23 (diff)
downloadguix-patches-e8e1ace0394dd979a1ad5459ebb5b9247f7ff1d7.tar
guix-patches-e8e1ace0394dd979a1ad5459ebb5b9247f7ff1d7.tar.gz
gnu: guile-bytestructures: Install sld files.
* gnu/packages/guile.scm (guile-bytestructures): Build and install sld files in r7 repository. It fixes this kind of errors while using guile-bytestructures: ice-9/psyntax.scm:3245:33: ice-9/psyntax.scm:3245:33: Syntax error: /gnu/store/ny9mp091yw51ylv1q59z25z5vdw8bi56-profile/share/guile/site/2.2/bytestructures/guile/base.scm:8:19: include-from-path: file not found in path in subform "bytestructures/r7/base.exports.sld" of (include-from-path "bytestructures/r7/base.exports.sld")
-rw-r--r--gnu/packages/guile.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 32d67794e8..c2f31fc8a1 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1471,6 +1471,8 @@ is no support for parsing block and inline level HTML.")
effective))
(source (assoc-ref %build-inputs "source"))
(doc (string-append out "/share/doc/scheme-bytestructures"))
+ (sld-files (with-directory-excursion source
+ (find-files "bytestructures/r7" "\\.exports.sld$")))
(scm-files (filter (lambda (path)
(not (string-prefix? "bytestructures/r7" path)))
(with-directory-excursion source
@@ -1502,7 +1504,7 @@ is no support for parsing block and inline level HTML.")
file))
(error (format #f "Failed to compile ~s to ~s!"
file go-file)))))
- scm-files)
+ (append sld-files scm-files))
;; Also copy over the README.
(install-file "README.md" doc)