summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-11-16 21:36:44 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-02 21:53:43 +0100
commite6ab1ab27d30e04e0adf3c5b1b0443b50a5687e6 (patch)
tree49011bcd0fffc4cd5faa9f986835230a50efab7b
parent369c3fef59a7ad532a99326b65adf6b201bad73e (diff)
downloadguix-patches-e6ab1ab27d30e04e0adf3c5b1b0443b50a5687e6.tar
guix-patches-e6ab1ab27d30e04e0adf3c5b1b0443b50a5687e6.tar.gz
gnu: Add rust-signature-derive-1.
* gnu/packages/crates-io.scm (rust-signature-derive-1): New variable.
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fe48e4c15f..e3180a0435 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26039,6 +26039,34 @@ words, like Python's shlex.")
(description "Backend crate for signal-hook.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-signature-derive-1
+ (package
+ (name "rust-signature-derive")
+ (version "1.0.0-pre.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "signature_derive" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0wp8b8ald7qixrcvvclhdcpmn8hkx049jlc29g57ql0304c6qrdh"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1)
+ ("rust-synstructure" ,rust-synstructure-0.12))))
+ (home-page "signature_derive")
+ (synopsis "Custom derive support for the 'signature' crate")
+ (description "This package provides proc macros used by the signature
+crate.
+
+It's not intended to be used directly. See the signature crate's documentation
+for additional details.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-simba-0.1
(package
(name "rust-simba")