summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-18 01:39:43 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-02 21:53:42 +0100
commitc12601ef58e172949f6d3778df97d5d11a61053d (patch)
tree321c59d9a4f512cb4305ce675f3899188e59bcd0
parent639f64823b3c038f752695947dacfc571ec0cf2f (diff)
downloadguix-patches-c12601ef58e172949f6d3778df97d5d11a61053d.tar
guix-patches-c12601ef58e172949f6d3778df97d5d11a61053d.tar.gz
gnu: Add rust-rpassword-5.
* gnu/packages/crates-io.scm (rust-rpassword-5): New variable, skipping build. (rust-rpassword-4): Inherit from rust-rpassword-5.
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 82e37a0f8d..5ad062be40 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22423,20 +22423,21 @@ Rust Language Server.")
rust.")
(license license:mpl2.0)))
-(define-public rust-rpassword-4
+(define-public rust-rpassword-5
(package
(name "rust-rpassword")
- (version "4.0.5")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "rpassword" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "17z99xazhhbaczw0ib1vnnq450j0zacdn8b2zcbdir68sdbicdwr"))))
+ (base32 "1j96nc3dmqhxwb4ql50r5xjs0imwr2x6mrj02mj9i7grq1zj6mfp"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
+ `(#:skip-build? #t
+ #:cargo-inputs
(("rust-libc" ,rust-libc-0.2)
("rust-winapi" ,rust-winapi-0.3))))
(home-page "https://github.com/conradkleinespel/rpassword")
@@ -22445,6 +22446,19 @@ rust.")
console applications.")
(license license:asl2.0)))
+(define-public rust-rpassword-4
+ (package
+ (inherit rust-rpassword-5)
+ (name "rust-rpassword")
+ (version "4.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rpassword" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "17z99xazhhbaczw0ib1vnnq450j0zacdn8b2zcbdir68sdbicdwr"))))))
+
(define-public rust-rpassword-3
(package
(inherit rust-rpassword-4)