summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex ter Weele <alex.ter.weele@gmail.com>2018-02-20 18:49:41 -0600
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 01:29:54 +0100
commit9f29ecc1b1d1da57afea71cf1a028a84a9399003 (patch)
tree3da112efb4726554793fbb781b5a86c720220b8b
parentacc55e836604f6d201ba2378864cae92bc765f69 (diff)
downloadguix-patches-9f29ecc1b1d1da57afea71cf1a028a84a9399003.tar
guix-patches-9f29ecc1b1d1da57afea71cf1a028a84a9399003.tar.gz
gnu: ghc-edit-distance: Allow newer version of QuickCheck.
* gnu/packages/haskell.scm (ghc-edit-distance)[arguments]: Allow running tests with newer version of QuickCheck. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/haskell.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e62c405ab7..737b7a4cd1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5755,6 +5755,8 @@ representations of current time.")
(sha256
(base32 "0jkca97zyv23yyilp3jydcrzxqhyk27swhzh82llvban5zp8b21y"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags (list "--allow-newer=QuickCheck")))
(inputs
`(("ghc-random" ,ghc-random)
("ghc-test-framework" ,ghc-test-framework)