summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-07 16:38:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:14 +0200
commit77d7b57cdcc22a4ab6fc4b52e2edfeb974954f57 (patch)
treeeff3da968fc98ccc1623fa46874baccdbf784e00
parentff3f67668d045c6c1affca3d0dc9c65764e98196 (diff)
downloadguix-patches-77d7b57cdcc22a4ab6fc4b52e2edfeb974954f57.tar
guix-patches-77d7b57cdcc22a4ab6fc4b52e2edfeb974954f57.tar.gz
gnu: Add java-simple-xml.
* gnu/packages/xml.scm (java-simple-xml): New variable.
-rw-r--r--gnu/packages/xml.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 79210d44d0..9635413b8f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -44,6 +44,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix build-system ant)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -1175,3 +1176,33 @@ to read and write XML data. A shared library is provided for parsing,
generating, manipulating, and validating XML documents using the DOM, SAX, and
SAX2 APIs.")
(license license:asl2.0)))
+
+(define-public java-simple-xml
+ (package
+ (name "java-simple-xml")
+ (version "2.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/simple/simple-xml-"
+ version ".zip"))
+ (sha256
+ (base32
+ "0w19k1awslmihpwsxwjbg89hv0vjhk4k3i0vrfchy3mqknd988y5"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:build-target "build"
+ #:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install (install-jars "jar")))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "http://simple.sourceforge.net/")
+ (synopsis "XML serialization framework for Java")
+ (description "Simple is a high performance XML serialization and
+configuration framework for Java. Its goal is to provide an XML framework
+that enables rapid development of XML configuration and communication systems.
+This framework aids the development of XML systems with minimal effort and
+reduced errors. It offers full object serialization and deserialization,
+maintaining each reference encountered.")
+ (license license:asl2.0)))