summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-14 00:21:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-14 00:23:00 +0200
commit1e58798bc4cd8d05bc0f8a3221fea1b67dd4d90a (patch)
tree32d1e637098667e16d809a56d1d58235a52d6c18
parentce4a497b132a63784cd64aca5223c92e061013fa (diff)
downloadguix-patches-1e58798bc4cd8d05bc0f8a3221fea1b67dd4d90a.tar
guix-patches-1e58798bc4cd8d05bc0f8a3221fea1b67dd4d90a.tar.gz
gnu: jasper: Update to 2.0.20 [fixes CVE-2016-9398's revenge].
* gnu/packages/image.scm (jasper): Update to 2.0.20. [arguments]: Skip tests of the now-disabled MIF image format.
-rw-r--r--gnu/packages/image.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 6604ac5359..4606cc77b2 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1409,7 +1409,7 @@ convert, manipulate, filter and display a wide variety of image formats.")
(define-public jasper
(package
(name "jasper")
- (version "2.0.19")
+ (version "2.0.20")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1418,8 +1418,20 @@ convert, manipulate, filter and display a wide variety of image formats.")
(file-name (git-file-name name version))
(sha256
(base32
- "036rcr0wkz9gzmvk1jb96piznk0c0bwxgf31z1zrlg8js4zl1n84"))))
+ "1bn4mg6l5afryrlyk3y7p3accdq113fis8hpwywy5g51ycablz3h"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-checking-disabled-things
+ (lambda _
+ ;; The MIF codec was disabled for security reasons in JasPer 2.0.20
+ ;; but its test suite still assumes that the format is supported.
+ (for-each delete-file
+ (find-files "data/test" "\\.mif$")) ; for run_test_1
+ (substitute* "test/bin/run_test_2"
+ (("image_formats\\+=\\(mif\\)") ""))
+ #t)))))
(inputs `(("libjpeg" ,libjpeg-turbo)))
(synopsis "JPEG-2000 library")
(description "The JasPer Project is an initiative to provide a reference