summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-26 20:53:39 -0400
committerLeo Famulari <leo@famulari.name>2016-10-26 21:41:28 -0400
commitfad8bf977d5443ac9ce9ac29a7a700f2c6170d40 (patch)
tree713c128f710976ae76d236d35e8d0fcb495ad9e0
parent02c73adcdf0f29dbecd9a1bb3c9be3626cd5dea9 (diff)
downloadguix-patches-fad8bf977d5443ac9ce9ac29a7a700f2c6170d40.tar
guix-patches-fad8bf977d5443ac9ce9ac29a7a700f2c6170d40.tar.gz
gnu: python-s3transfer: Run the tests.
* gnu/packages/python.scm (python-s3transfer, python2-s3transfer)[arguments]: Use python-nose to run the tests. [native-inputs]: Add python-mock and python-nose.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ba1e0c424d..4215c3dc7f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11212,8 +11212,18 @@ replay them during future tests. It is designed to work with python-requests.")
(base32
"1jivjkp3xqif9gzr5fiq28jsskmh50vzzd7ldsb4rbyiw1iyv3hy"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; 7 of the 'integration' tests require network access or login
+ ;; credentials.
+ (zero? (system* "nosetests" "--exclude=integration")))))))
(native-inputs
- `(("python-docutils" ,python-docutils)))
+ `(("python-docutils" ,python-docutils)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
(inputs
`(("python-botocore" ,python-botocore)))
(synopsis "Amazon S3 Transfer Manager")