summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-15 22:16:30 -0400
committerLeo Famulari <leo@famulari.name>2016-10-15 22:20:38 -0400
commitca0eee9df5b048dbf509a91c3b78a805fd1e2200 (patch)
tree9d4e2759f07bf893b83b5035f7286a720a1fc5e7
parent31c580068ba1eda69f72ad1f672c8508e59cf7f4 (diff)
downloadguix-patches-ca0eee9df5b048dbf509a91c3b78a805fd1e2200.tar
guix-patches-ca0eee9df5b048dbf509a91c3b78a805fd1e2200.tar.gz
gnu: python-execnet: Disable tests.
The tests were silently skipped with Python 3.4. With Python 3.5, this caused the python-execnet build to fail. * gnu/packages/python.scm (python-execnet, python2-execnet)[arguments]: Disable tests.
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 02ec731c40..f6917ba86a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7311,8 +7311,14 @@ pure Python module that works on virtually all Python versions.")
(base32
"1rpk1vyclhg911p3hql0m0nrpq7q7mysxnaaw6vs29cpa6kx8vgn"))))
(build-system python-build-system)
+ (arguments
+ `(;; 2 failed, 275 passed, 670 skipped, 4 xfailed
+ ;; The two test failures are caused by the lack of an `ssh` executable.
+ ;; The test suite can be run with pytest after the 'install' phase.
+ #:tests? #f))
(native-inputs
- `(("python-setuptools-scm" ,python-setuptools-scm)))
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
(inputs
`(("python-apipkg" ,python-apipkg)))
(synopsis "Rapid multi-Python deployment")