summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-16 13:05:30 -0400
committerLeo Famulari <leo@famulari.name>2016-10-17 13:54:51 -0400
commita9871b7b523eefba58645b20c88a2499119ca48e (patch)
tree786c7d5c9ea1a6312b1483fede1e8770dfd1a7bf
parent8757f05046dfc2423edc0345c6da21d2e0a6257e (diff)
downloadguix-patches-a9871b7b523eefba58645b20c88a2499119ca48e.tar
guix-patches-a9871b7b523eefba58645b20c88a2499119ca48e.tar.gz
gnu: python-vobject: Disable the test suite.
The tests were silently skipped with Python 3.4. With Python 3.5, this caused the python-vobject build to fail. * gnu/packages/python.scm (python-vobject, python2-vobject)[arguments]: Disable the tests.
-rw-r--r--gnu/packages/python.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8d2195cefc..7938f74b66 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8742,6 +8742,9 @@ introspection of @code{zope.interface} instances in code.")
(base32
"1qfnwlx8qwkgr6nf5wvl6ff1r3kll53dh3z6nyp173nmlhhhqccb"))))
(build-system python-build-system)
+ (arguments
+ '(;; The test suite relies on some non-portable Windows interfaces.
+ #:tests? #f))
(inputs
`(("python-dateutil-2" ,python-dateutil-2)
("python-pyicu" ,python-pyicu)))