summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-06 14:34:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-06 14:48:23 +0200
commit9e836ca8fcf97c4ed3aa41db6ed2fd47a142009a (patch)
tree2945866be26eac4c93a2c9d2c57814e00a1742c1
parent7158f8e4e9f81dbe004789018dcf06a5fe87d602 (diff)
downloadguix-patches-9e836ca8fcf97c4ed3aa41db6ed2fd47a142009a.tar
guix-patches-9e836ca8fcf97c4ed3aa41db6ed2fd47a142009a.tar.gz
gnu: Add r-cmdfun.
* gnu/packages/cran.scm (r-cmdfun): New variable.
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4fb5b2d25b..4e05568741 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11711,6 +11711,40 @@ using @dfn{penalized quasi-likelihood} (PQL) estimation (see Jaeger et
al. (2016)).")
(license license:gpl2)))
+(define-public r-cmdfun
+ (package
+ (name "r-cmdfun")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cmdfun" version))
+ (sha256
+ (base32
+ "1pbcq7hi2lcmqnghmy3q2fsk0c9fy5m0637acyzmc096fxbx723j"))))
+ (properties `((upstream-name . "cmdfun")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-magrittr" ,r-magrittr)
+ ("r-purrr" ,r-purrr)
+ ("r-r-utils" ,r-r-utils)
+ ("r-rlang" ,r-rlang)
+ ("r-testthat" ,r-testthat)
+ ("r-usethis" ,r-usethis)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://snystrom.github.io/cmdfun/")
+ (synopsis "Framework for building interfaces to shell commands")
+ (description
+ "Writing interfaces to command line software is cumbersome. The cmdfun
+package provides a framework for building function calls to seamlessly
+interface with shell commands by allowing lazy evaluation of command line
+arguments. It also provides methods for handling user-specific paths to tool
+installs or secrets like API keys. Its focus is to equally serve package
+builders who wish to wrap command line software, and to help analysts stay
+inside R when they might usually leave to execute non-R software.")
+ (license license:expat)))
+
(define-public r-weights
(package
(name "r-weights")