summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-22 17:55:35 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:11 -0500
commit995ef5ea11a9003abc0ea90b4ce61e53ef1eb679 (patch)
treecef5a2c2dd9902cc021e4cc19ebb8bdb46aea128
parent06323c8ed749b6e65c77e8e82382a2acba7df6ab (diff)
downloadguix-patches-995ef5ea11a9003abc0ea90b4ce61e53ef1eb679.tar
guix-patches-995ef5ea11a9003abc0ea90b4ce61e53ef1eb679.tar.gz
gnu: totem: Update to 3.32.1.
* gnu/packages/gnome.scm (totem): Update to 3.32.1. [source]: Remove patches. [arguments]: Add 'pre-check' phase. Remove #:parallel-build?. [native-inputs]: Add python-pylint and xorg-server-for-tests. [inputs]: Replace python2-pygobject with python-pygobject. * gnu/packages/patches/totem-meson-easy-codec.patch, gnu/packages/patches/totem-meson-compat.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/gnome.scm27
-rw-r--r--gnu/packages/patches/totem-meson-compat.patch14
-rw-r--r--gnu/packages/patches/totem-meson-easy-codec.patch65
4 files changed, 13 insertions, 95 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5135cdd30c..7744566996 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1403,8 +1403,6 @@ dist_patch_DATA = \
%D%/packages/patches/ttf2eot-cstddef.patch \
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
%D%/packages/patches/tomb-fix-errors-on-open.patch \
- %D%/packages/patches/totem-meson-compat.patch \
- %D%/packages/patches/totem-meson-easy-codec.patch \
%D%/packages/patches/tuxpaint-stamps-path.patch \
%D%/packages/patches/txr-shell.patch \
%D%/packages/patches/u-boot-fix-mkimage-header-verification.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b0d98e3c9b..8ff04ada86 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4139,7 +4139,7 @@ for application developers.")
(define-public totem
(package
(name "totem")
- (version "3.30.0")
+ (version "3.32.1")
(source
(origin
(method url-fetch)
@@ -4148,9 +4148,7 @@ for application developers.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0rahkybxbmxhlmrrgrzxny1xm7wycx7ib4blxp1i2l1q3i8s84b0"))
- (patches (search-patches "totem-meson-easy-codec.patch"
- "totem-meson-compat.patch"))))
+ "0yra8apc7smpwf7d1k8crhrm8d4wix24ds6i9yxbch1v11jnhr3v"))))
(build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -4159,7 +4157,9 @@ for application developers.")
("glib:bin" ,glib "bin") ;for 'glib-mkenums'
("intltool" ,intltool)
("itstool" ,itstool)
- ("xmllint" ,libxml2)))
+ ("xmllint" ,libxml2)
+ ("python-pylint" ,python-pylint)
+ ("xorg-server" ,xorg-server-for-tests)))
(propagated-inputs
`(("dconf" ,dconf)))
(inputs
@@ -4187,8 +4187,7 @@ for application developers.")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("adwaita-icon-theme" ,adwaita-icon-theme)
("python" ,python)
- ("python-pygobject" ,python2-pygobject)
- ;; XXX TODO pylint needed for python support
+ ("python-pygobject" ,python-pygobject)
("totem-pl-parser" ,totem-pl-parser)
("grilo" ,grilo)
("grilo-plugins" ,grilo-plugins)
@@ -4196,12 +4195,6 @@ for application developers.")
(arguments
`(#:glib-or-gtk? #t
- ;; Disable parallel builds until
- ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=28813 is
- ;; fixed. Try enabling it when updating this package in case
- ;; upstream has fixed it.
- #:parallel-build? #f
-
;; Disable automatic GStreamer plugin installation via PackageKit and
;; all that.
#:configure-flags '("-D" "enable-easy-codec-installation=no"
@@ -4209,7 +4202,6 @@ for application developers.")
;; Do not build .a files for the plugins, it's
;; completely useless. This saves 2 MiB.
"--default-library" "shared")
-
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -4223,6 +4215,13 @@ for application developers.")
(lambda _
(setenv "DESTDIR" "/")
#t))
+ (add-before
+ 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ #t))
(add-after
'install 'wrap-totem
(lambda* (#:key inputs outputs #:allow-other-keys)
diff --git a/gnu/packages/patches/totem-meson-compat.patch b/gnu/packages/patches/totem-meson-compat.patch
deleted file mode 100644
index 8557908dd0..0000000000
--- a/gnu/packages/patches/totem-meson-compat.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fix an error that occurs with Meson 0.50.0 and later:
-"ERROR: Subdir keyword must not be an absolute path".
-
---- a/src/meson.build 2019-03-15 00:10:26.882293850 +0100
-+++ b/src/meson.build 2019-03-15 00:10:54.312197229 +0100
-@@ -82,7 +82,7 @@
-
- install_headers(
- headers,
-- subdir: join_paths(totem_includedir, totem_api_path)
-+ install_dir: join_paths(totem_includedir, totem_api_path)
- )
-
- libtotem_player_sources = files(
diff --git a/gnu/packages/patches/totem-meson-easy-codec.patch b/gnu/packages/patches/totem-meson-easy-codec.patch
deleted file mode 100644
index b97d555c1a..0000000000
--- a/gnu/packages/patches/totem-meson-easy-codec.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Fix a bug whereby the 'have_easy_codec' would be left undefined
-when passing '-D enable-easy-codec-installation=no'. Likewise,
-don't rely on GStreamer's plug-in support when it's disabled.
-
---- totem-3.26.0/meson.build 2017-10-11 22:29:44.506280919 +0200
-+++ totem-3.26.0/meson.build 2017-10-11 22:29:50.902252058 +0200
-@@ -203,6 +203,8 @@ if easy_codec_option != 'no'
- missing_plugins_deps += gst_pbutils_dep
- config_h.set('ENABLE_MISSING_PLUGIN_INSTALLATION', have_easy_codec,
- description: 'Whether we can and want to do installation of missing plugins')
-+else
-+ have_easy_codec = false
- endif
-
- # python support
-
---- totem-3.26.0/src/backend/bacon-video-widget.c 2017-10-11 22:40:52.531217356 +0200
-+++ totem-3.26.0/src/backend/bacon-video-widget.c 2017-10-11 22:45:44.973847231 +0200
-@@ -341,6 +341,22 @@ get_type_name (GType class_type, int typ
- return value->value_nick;
- }
-
-+#ifndef ENABLE_MISSING_PLUGIN_INSTALLATION
-+
-+gchar *
-+gst_missing_plugin_message_get_installer_detail (GstMessage *message)
-+{
-+ return NULL;
-+}
-+
-+char *
-+gst_missing_plugin_message_get_description (GstMessage *message)
-+{
-+ return NULL;
-+}
-+
-+#endif
-+
- static gchar **
- bvw_get_missing_plugins_foo (const GList * missing_plugins, MsgToStrFunc func)
- {
-@@ -1654,10 +1670,12 @@ bvw_handle_element_message (BaconVideoWi
- }
- }
- goto done;
-+#ifdef ENABLE_MISSING_PLUGIN_INSTALLATION
- } else if (gst_is_missing_plugin_message (msg)) {
- bvw->priv->missing_plugins =
- g_list_prepend (bvw->priv->missing_plugins, gst_message_ref (msg));
- goto done;
-+#endif
- } else if (strcmp (type_name, "not-mounted") == 0) {
- const GValue *val;
- GFile *file;
-@@ -6109,7 +6127,9 @@ bacon_video_widget_initable_init (GInita
- GST_DEBUG ("Initialised %s", version_str);
- g_free (version_str);
-
-+#ifdef ENABLE_MISSING_PLUGIN_INSTALLATION
- gst_pb_utils_init ();
-+#endif
-
- /* Instantiate all the fallible plugins */
- bvw->priv->play = element_make_or_warn ("playbin", "play");
-