summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-10-01 10:33:38 -0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-01 20:27:04 +0200
commit8827ef8a50bf51d43552d2b65aa1f7088b338140 (patch)
tree3420654ac5f7dee32db3f0dbd89f9c0e92f9b169
parent1aa7f017e84491c83e4e90121a31ece6383abe2b (diff)
downloadguix-patches-8827ef8a50bf51d43552d2b65aa1f7088b338140.tar
guix-patches-8827ef8a50bf51d43552d2b65aa1f7088b338140.tar.gz
gnu: Add guile-pipe.
* gnu/packages/guile-xyz.scm (guile-pipe): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/guile-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 7188058b42..6936e9699b 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -256,6 +256,33 @@ more.")
(home-page "https://www.gnu.org/software/artanis/")
(license (list license:gpl3+ license:lgpl3+)))) ;dual license
+;; There are no releases yet of this package.
+(define-public guile-pipe
+ (let ((commit "0746ec38d19d844dff0c6f62f209b2b6c8d8872e")
+ (revision "0"))
+ (package
+ (name "guile-pipe")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joshwalters/guile-pipe")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "038gwrhfywgs8372q478wn4623lhcmkknfj4p8yaa93bykfc0fml"))))
+ (build-system guile-build-system)
+ (native-inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://github.com/joshwalters/guile-pipe")
+ (synopsis "Guile pipe macros for functional chaining")
+ (description
+ "This package provides macros for functional chaining in Guile, similar
+to UNIX pipes (@code{|}), Clojure's threading macros (@code{->} and
+@code{->>}).")
+ (license license:gpl3+))))
+
(define-public guile-f-scm
(package
(name "guile-f-scm")