summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-23 01:05:36 -0400
committerMark H Weaver <mhw@netris.org>2015-04-23 01:06:40 -0400
commit60e2d5fe822160b333acbb8597501cb3b487692d (patch)
tree8a72c135aee46e8fe3dc9f197a84b25e6ad1c37d
parent2f8339c8abf5c4b1ed9e33cab889d80af45aec35 (diff)
downloadguix-patches-60e2d5fe822160b333acbb8597501cb3b487692d.tar
guix-patches-60e2d5fe822160b333acbb8597501cb3b487692d.tar.gz
gnu: Add gcc-5.1.0 and gcc-toolchain-5.1.0.
* gnu/packages/gcc.scm (gcc-5.1): New variable. * gnu/packages/commencement.scm (gcc-toolchain-5.1): New variable.
-rw-r--r--gnu/packages/commencement.scm5
-rw-r--r--gnu/packages/gcc.scm12
2 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 22da2e0fb3..4a9fc5b205 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -770,4 +770,7 @@ and binaries, plus debugging symbols in the 'debug' output), and Binutils.")
(define-public gcc-toolchain-4.9
(gcc-toolchain gcc-4.9))
+(define-public gcc-toolchain-5.1
+ (gcc-toolchain gcc-5.1))
+
;;; commencement.scm ends here
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index cd6fc3b2fd..e712e43b1f 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -324,6 +324,18 @@ Go. It also includes runtime support libraries for these languages.")
"1pbjp4blk2ycaa6r3jmw4ky5f1s9ji3klbqgv8zs2sl5jn1cj810"))
(patches (list (search-patch "gcc-arm-link-spec-fix.patch")))))))
+(define-public gcc-5.1
+ (package (inherit gcc-4.7)
+ (version "5.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1bd5vj4px3s8nlakbgrh38ynxq4s654m6nxz7lrj03mvkkwgvnmp"))
+ (patches (list (search-patch "gcc-arm-link-spec-fix.patch")))))))
+
(define* (custom-gcc gcc name languages #:key (separate-lib-output? #t))
"Return a custom version of GCC that supports LANGUAGES."
(package (inherit gcc)