summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-29 22:16:47 -0400
committerLeo Famulari <leo@famulari.name>2016-10-29 22:16:47 -0400
commit593dfdc33b071f5f0c2d51d9b7f81d36b7c2133e (patch)
tree89ddf245b92e0e3f1528b9ff3e4b19059052494d
parentad967bf08d008712bd40296da9cfd4c0c0c214cd (diff)
parent59f129855888b18bd0ff39d2427841d9c6714b57 (diff)
downloadguix-patches-593dfdc33b071f5f0c2d51d9b7f81d36b7c2133e.tar
guix-patches-593dfdc33b071f5f0c2d51d9b7f81d36b7c2133e.tar.gz
Merge branch 'master' into core-updates
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 06f813098f..25e06e994b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8382,6 +8382,9 @@ layouts.")
(base32
"0j9fsisip21qv4xljsg5dmni1pgpvwrjyyhhql0glydc4bs5rjgv"))))
(build-system python-build-system)
+ (native-inputs
+ `(("python-webob" ,python-webob)
+ ("python-webtest" ,python-webtest)))
(propagated-inputs
`(("python-lxml" ,python-lxml)
("python-cssselect" ,python-cssselect)))
@@ -8398,7 +8401,8 @@ fast xml and html manipulation.")
(strip-python2-variant python-pyquery))))
(package
(inherit pyquery)
- (native-inputs `(("python2-setuptools" ,python2-setuptools))))))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs pyquery))))))
(define-public python-webtest
(package
@@ -10538,6 +10542,10 @@ binary or text.")
(base32
"0skxbhnymwlspjkzga0f7x1hg3y50fwpfghs8g8k7fh6f4nknlym"))))
(build-system python-build-system)
+ (arguments
+ '(;; The tests require some extra resources to be downloaded.
+ ;; TODO Try packaging these resources.
+ #:tests? #f))
(home-page "http://nltk.org/")
(synopsis "Natural Language Toolkit")
(description "It provides interfaces to over 50 corpora and lexical