summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-05 18:02:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-05 19:33:10 +0200
commit53428597a690b409cdb66070ca4397ed76015e20 (patch)
tree6733f588d3fd4074570e97fd72391bb96124829b
parent28d6b57c38abf8843ef02d85178755790db824a6 (diff)
downloadguix-patches-53428597a690b409cdb66070ca4397ed76015e20.tar
guix-patches-53428597a690b409cdb66070ca4397ed76015e20.tar.gz
gnu: strace: Update to 5.7.
* gnu/packages/linux.scm (strace): Update to 5.7. [arguments]: Disable three failing tests.
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f61ce864af..745370b8f8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1788,7 +1788,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(define-public strace
(package
(name "strace")
- (version "5.5")
+ (version "5.7")
(home-page "https://strace.io")
(source (origin
(method url-fetch)
@@ -1796,7 +1796,7 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
"/strace-" version ".tar.xz"))
(sha256
(base32
- "1zrhpzjlgfwfl8dd53llswmmharm5rbi0zch7lln5sjris69an4z"))))
+ "1n6cfz3i2krkyvxpdp3kmxhf7sy5xp0danzaiirbk5fdkfgvb15j"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -1805,6 +1805,12 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(lambda _
(substitute* "strace.c"
(("/bin/sh") (which "sh")))
+ #t))
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; XXX These hang forever even if the test time-out is extended.
+ (substitute* "tests/Makefile.in"
+ (("^\tstrace-DD?D?\\.test \\\\.*") ""))
#t)))
;; Don't fail if the architecture doesn't support different personalities.
#:configure-flags '("--enable-mpers=check")