summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-12-07 21:28:18 +0100
committerMarius Bakke <marius@gnu.org>2020-12-08 00:45:56 +0100
commit403dda2e66dc5c8f23bf66086815133546df1ba0 (patch)
tree9f8ba92dbf9eb50833702563e2b2725bb0e2bb61
parentadf0edadef9a60766f5786ab789d26a8248ab4d4 (diff)
downloadguix-patches-403dda2e66dc5c8f23bf66086815133546df1ba0.tar
guix-patches-403dda2e66dc5c8f23bf66086815133546df1ba0.tar.gz
gnu: shadowsocks: Build against openssl.
This patch allows shadowsocks to be used without supplying libopenssl in its configuration. See also https://unix.stackexchange.com/questions/623324/. * gnu/packages/networking.scm (shadowsocks)[inputs]: Add openssl. [#:phases]: Add patch-crypto-paths. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/networking.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8a84c8476a..1226b8606f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3024,6 +3024,19 @@ asynchronous model using a modern C++ approach.")
(base32
"1idd9b4f2pnhcpk1bh030hqg5zq25gkwxd53xi3c0cj242w7sp2j"))
(file-name (git-file-name name version))))
+ (inputs
+ `(("openssl" ,openssl)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-crypto-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "shadowsocks/shell.py"
+ (("config\\.get\\('libopenssl', None\\)")
+ (format #f "config.get('libopenssl', ~s)"
+ (string-append
+ (assoc-ref inputs "openssl")
+ "/lib/libssl.so")))))))))
(build-system python-build-system)
(synopsis "Fast tunnel proxy that helps you bypass firewalls")
(description