summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 09:22:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:55 +0100
commit07d958fe0edb21df38541cc3a9eabf0ae1ab9f84 (patch)
tree98be884c57c65a09878e9113b613b357a7b3c7fe
parent49e9a9aea2131f39c44689aebf02a87887cc0f87 (diff)
downloadguix-patches-07d958fe0edb21df38541cc3a9eabf0ae1ab9f84.tar
guix-patches-07d958fe0edb21df38541cc3a9eabf0ae1ab9f84.tar.gz
gnu: Add r-acss-data.
* gnu/packages/cran.scm (r-acss-data): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 76bae8ec93..37f8e8d877 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17697,3 +17697,30 @@ are converted to standard errors to be bundled with estimates in complex
operations on @code{acs} objects and present/plot data in statistically
appropriate ways.")
(license license:gpl3)))
+
+(define-public r-acss-data
+ (package
+ (name "r-acss-data")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "acss.data" version))
+ (sha256
+ (base32
+ "09kl4179ipr8bq19g89xcdi1xxs397zcx5cvgp6viy8gn687ilgv"))))
+ (properties `((upstream-name . "acss.data")))
+ (build-system r-build-system)
+ (home-page "http://complexitycalculator.com/methodology.html")
+ (synopsis "Data for algorithmic complexity of short strings")
+ (description
+ "This is a data only package providing the algorithmic complexity of
+short strings, computed using the coding theorem method. For a given set of
+symbols in a string, all possible or a large number of random samples of
+Turing machines with a given number of states (e.g., 5) and number of symbols
+corresponding to the number of symbols in the strings were simulated until
+they reached a halting state or failed to end. This package contains data on
+4.5 million strings from length 1 to 12 simulated on Turing machines with 2,
+4, 5, 6, and 9 symbols. The complexity of the string corresponds to the
+distribution of the halting states.")
+ (license license:gpl2+)))