summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-01-14 18:13:08 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-23 23:21:05 +0100
commitfeb22a2037872685cd3b0ef5c83010d7624764c1 (patch)
tree8e6a95fea65b096d42d9219a27c2d12b5aa750af
parent0406aa2b8f6a9bd6beab9780f7554aa265eb2c28 (diff)
downloadguix-patches-feb22a2037872685cd3b0ef5c83010d7624764c1.tar
guix-patches-feb22a2037872685cd3b0ef5c83010d7624764c1.tar.gz
gnu: Add rofi-calc.
* gnu/packages/xdisorg.scm (rofi-calc): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xdisorg.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index eb94a00561..ec995c3496 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -78,6 +78,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system scons)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix hg-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -1741,6 +1742,51 @@ applications you regularly use and also allows you to search for an application
by name.")
(license license:expat)))
+(define-public rofi-calc
+ (package
+ (name "rofi-calc")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/svenstaro/rofi-calc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j23xwa6s27wyx6r0yb85cby6dggrcb103nqcfxr5li1mcqrgd9m"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Don't try to install directly to rofi, instead install
+ ;; to lib/rofi to match rofi's search-path ROFI_PLUGIN_PATH.
+ (add-after 'unpack 'patch-plugindir
+ (lambda _
+ (substitute* "Makefile.am"
+ (("plugindir=\\$\\{rofi_PLUGIN_INSTALL_DIR\\}\\/")
+ "plugindir=${libdir}/rofi/"))))
+ (add-after 'unpack 'patch-qalc-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/calc.c"
+ (("\"qalc\"")
+ (string-append "\""
+ (search-input-file inputs "bin/qalc")
+ "\""))))))))
+ (inputs
+ (list cairo libqalculate rofi))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (home-page
+ "https://github.com/svenstaro/rofi-calc")
+ (synopsis "Do live calculations in rofi with qalc")
+ (description
+ "@code{rofi-calc} is a rofi plugin that uses qalculate's @code{qalc} to parse
+natural language input and provide results.")
+ (license license:expat)))
+
(define-public tint2
(package
(name "tint2")