summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-01-24 14:18:08 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-24 15:39:16 +0100
commitc9627323eca0fb1e0b0a0680049ea0f9f20def5e (patch)
tree1d3309d464890c43e76dc88c4727a57e9d2260c0
parent1bfd634e335702d0b9b0189d685d14ec79f1cbf6 (diff)
downloadguix-patches-c9627323eca0fb1e0b0a0680049ea0f9f20def5e.tar
guix-patches-c9627323eca0fb1e0b0a0680049ea0f9f20def5e.tar.gz
gnu: guile@2.0: Build with '-fexcess-precision=standard' on i686.
Fixes <https://issues.guix.gnu.org/53462>. Reported by Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>. This is a followup to 9b09a753a9711f7614564272013138fce6fec708. * gnu/packages/guile.scm (guile-2.0)[arguments]: Augment #:configure-flags when 'target-x86-32?'. (guile-2.2)[arguments]: Tweak #:configure-flags to keep derivation unchanged. (guile-3.0)[arguments]: Likewise.
-rw-r--r--gnu/packages/guile.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 55c89cafab..6cfd609916 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -187,7 +187,10 @@ without requiring the source code to be rewritten.")
(outputs '("out" "debug"))
(arguments
- `(#:configure-flags '("--disable-static") ; saves 3 MiB
+ `(#:configure-flags
+ ,(if (target-x86-32?) ;<https://issues.guix.gnu.org/49368>
+ ''("--disable-static" "CFLAGS=-g -O2 -fexcess-precision=standard")
+ ''("--disable-static")) ;saves 3 MiB
;; Work around non-reproducible .go files as described in
;; <https://bugs.gnu.org/20272>, which affects 2.0, 2.2, and 3.0 so far.
@@ -273,7 +276,8 @@ without requiring the source code to be rewritten.")
(substitute-keyword-arguments (package-arguments guile-2.0)
((#:configure-flags flags ''())
(if (target-x86-32?) ;<https://issues.guix.gnu.org/49368>
- `(append ,flags '("CFLAGS=-g -O2 -fexcess-precision=standard"))
+ `(append '("--disable-static")
+ '("CFLAGS=-g -O2 -fexcess-precision=standard"))
flags))))
(properties '((timeout . 72000) ;20 hours
@@ -345,7 +349,7 @@ without requiring the source code to be rewritten.")
'("CFLAGS=-g -O2 -fexcess-precision=standard")
'())
"--enable-mini-gmp"
- ,flags))
+ '("--disable-static")))
((#:phases phases)
`(modify-phases ,phases
(add-before 'check 'disable-stack-overflow-test