summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-12 20:19:31 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-12 20:19:31 +0100
commita6ac8332be8ef2a275419a185ba4efae01973253 (patch)
treea85c8bca5ab6e8986cc3cdee9355e4772f7118c1
parente58d01faf5780db0efa54f0b40f63acd18e1b30c (diff)
downloadguix-patches-a6ac8332be8ef2a275419a185ba4efae01973253.tar
guix-patches-a6ac8332be8ef2a275419a185ba4efae01973253.tar.gz
gnu: Add python-apsw.
* gnu/packages/python.scm (python-apsw, python2-apsw): New variables.
-rw-r--r--gnu/packages/python.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 36acfc0ed3..cc67dd0680 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2947,3 +2947,41 @@ implementation of D-Bus.")
;; FIXME: on Python 2, the test_utf8 fails with:
;; "ValueError: unichr() arg not in range(0x10000) (narrow Python build)"
(arguments `(#:tests? #f))))
+
+(define-public python-apsw
+ (package
+ (name "python-apsw")
+ (version "3.8.7.3-r1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/a/apsw/apsw-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1rgxdypg7hym0qny15rx5khrghx9fkppfgsfa2s8lg917924mv7l"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("sqlite" ,sqlite)))
+ (arguments
+ `(#:phases
+ ;; swap check and install phases
+ (alist-cons-after
+ 'install 'check
+ (assoc-ref %standard-phases 'check)
+ (alist-delete
+ 'check
+ %standard-phases))))
+ (home-page "https://github.com/rogerbinns/apsw/")
+ (synopsis "Another Python SQLite Wrapper")
+ (description "APSW is a Python wrapper for the SQLite
+embedded relational database engine. In contrast to other wrappers such as
+pysqlite it focuses on being a minimal layer over SQLite attempting just to
+translate the complete SQLite API into Python.")
+ (license zlib)))
+
+(define-public python2-apsw
+ (package-with-python2 python-apsw))