summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-01-22 03:59:16 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-23 23:27:22 +0100
commit967dd6ee069af8a0c939431b05cd24c153703fa6 (patch)
tree1b804fd678f3685ef4490886a22e7ae7e0f844e4
parentfeb22a2037872685cd3b0ef5c83010d7624764c1 (diff)
downloadguix-patches-967dd6ee069af8a0c939431b05cd24c153703fa6.tar
guix-patches-967dd6ee069af8a0c939431b05cd24c153703fa6.tar.gz
gnu: gtk-vnc: Remove dependency on GJS on non-x86_64.
* gnu/packages/gnome.scm (gtk-vnc)[native-inputs]: Provide GJS only when 'target-x86-64?'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 41830102f6..d61a412f01 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -68,6 +68,7 @@
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8827,7 +8828,11 @@ like switching to windows and launching applications.")
(arguments
`(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
(native-inputs
- `(("gjs" ,gjs)
+ `(;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
+ ;; dependency on other platforms (FIXME).
+ ,@(if (target-x86-64?)
+ `(("gjs" ,gjs))
+ '())
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)