summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-23 20:22:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-23 22:24:09 +0200
commit656c7bc805f3f2aff2e13516ff39b4d0144a9756 (patch)
tree3f339a1c73545b037c6f7cdf0ee5711599ecdbbf
parentd7085a3c5001635ec2f63dabdd970ecf7d64a3f8 (diff)
downloadguix-patches-656c7bc805f3f2aff2e13516ff39b4d0144a9756.tar
guix-patches-656c7bc805f3f2aff2e13516ff39b4d0144a9756.tar.gz
gnu: python-pillow: Update to 9.0.0 (security fixes).
* gnu/packages/python-xyz.scm (python-pillow): Update to 9.0.0. [source]: Add snippet to remove bundled code. [arguments]: Adjust custom 'check phase.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 105a7aeb94..91b5be171e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2017, 2020 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
@@ -7089,14 +7089,18 @@ retrieve text and metadata from PDFs as well as merge entire files together.")
(define-public python-pillow
(package
(name "python-pillow")
- (version "8.1.1")
+ (version "9.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pillow" version))
(sha256
(base32
- "086g7nhv52wclrwnzbzs2x3nvyzs2hfq1bvgivsrp5f7r7wiiz7n"))))
+ "0gjry0yqryd2678sm47jhdnbghzxn5wk8pgyaqwr4qi7x5ijjvpf"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "src/thirdparty")))))
(build-system python-build-system)
(native-inputs
(list python-pytest))
@@ -7119,14 +7123,12 @@ retrieve text and metadata from PDFs as well as merge entire files together.")
(("\\['/sbin/ldconfig', '-p'\\]") "['true']"))))
(replace 'check
(lambda* (#:key outputs inputs tests? #:allow-other-keys)
- (if tests?
- (begin
- (setenv "HOME" (getcwd))
- ;; Make installed package available for running the tests.
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "selftest.py" "--installed")
- (invoke "python" "-m" "pytest" "-vv"))
- #t))))))
+ (when tests?
+ (setenv "HOME" (getcwd))
+ ;; Make installed package available for running the tests.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "selftest.py" "--installed")
+ (invoke "python" "-m" "pytest" "-vv")))))))
(home-page "https://python-pillow.org")
(synopsis "Fork of the Python Imaging Library")
(description