summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-23 17:06:17 +0100
committerMarius Bakke <marius@gnu.org>2022-01-23 19:59:09 +0100
commit61375770cbc379c75050db5896123647b31cd1f8 (patch)
tree86fd7540ce396c1a644eefc8a024f9a6881a80c5
parent3d553888c67687a17c64b44437dbd92a8920f559 (diff)
downloadguix-patches-61375770cbc379c75050db5896123647b31cd1f8.tar
guix-patches-61375770cbc379c75050db5896123647b31cd1f8.tar.gz
gnu: Add rust-inventory.
* gnu/packages/crates-io.scm (rust-inventory-0.1, rust-inventory-impl-0.1): New variables.
-rw-r--r--gnu/packages/crates-io.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 07439a796b..2522dce149 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28126,6 +28126,60 @@ bytestring representations.")
immutable interval tree.")
(license license:expat)))
+(define-public rust-inventory-0.1
+ (package
+ (name "rust-inventory")
+ (version "0.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "inventory" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1m1zdjgs3nzfdxf86mc1i0id56fvk8rfw63rf04yi88bqrh53szh"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-ctor" ,rust-ctor-0.1)
+ ("rust-ghost" ,rust-ghost-0.1)
+ ("rust-inventory-impl" ,rust-inventory-impl-0.1))))
+ (home-page "https://github.com/dtolnay/inventory")
+ (synopsis "Typed distributed plugin registration")
+ (description
+ "This package provides a way to set up a plugin registry into which
+plugins can be registered from any source file linked into your program.
+There does not need to be a central list of all the plugins.")
+ ;; Either license can be chosen at the users option.
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-inventory-impl-0.1
+ (package
+ (name "rust-inventory-impl")
+ (version "0.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "inventory-impl" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0j45a7nq4vircnz5m23db34527icxqnvh2si96zc9w662lvvahby"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://github.com/dtolnay/inventory")
+ (synopsis "Macros for the @code{inventory} crate")
+ (description
+ "This package provides macros for the @code{rust-inventory} package.
+It has been merged with the @code{inventory} crate and is only useful for
+versions < 0.2.")
+ ;; Either license can be chosen at the users option.
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-iovec-0.1
(package
(name "rust-iovec")