summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-12 21:20:50 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-23 23:03:34 +0100
commit4b4b981a2c1ef04ebd4b91cd5564a72a5ac05d58 (patch)
treee157120e77738157e200d45683a86145bd71efa0
parent3878cf96183a27d63d374378d3044fd091231d0c (diff)
downloadguix-patches-4b4b981a2c1ef04ebd4b91cd5564a72a5ac05d58.tar
guix-patches-4b4b981a2c1ef04ebd4b91cd5564a72a5ac05d58.tar.gz
gnu: Add font-charter.
* gnu/packages/fonts.scm (font-charter): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/fonts.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 8b618bf3b6..8afb453970 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2424,3 +2424,43 @@ In addition to Bravura itself, which is for use with music notation
software (such as MuseScore), the family includes a Bravura Text variant
optimized for using musical symbols inline with regular text.")
(license license:silofl1.1)))
+
+(define-public font-charter
+ (let ((butterick-version "210112")) ;; yymmdd
+ (package
+ (name "font-charter")
+ (version (string-append "2.0.0-" butterick-version))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://practicaltypography.com/fonts/Charter%20"
+ butterick-version ".zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32 "1j8iv2dl695zrabs2knb7jsky8mjis29a2ddpna4by8mlvqrf0ml"))))
+ (outputs '("out" "woff2"))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-woff2
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((dest (string-append (assoc-ref outputs "woff2")
+ "/share/fonts/woff2")))
+ (for-each (lambda (file)
+ (install-file file dest))
+ (find-files "." "\\.woff2$"))))))))
+ (home-page "https://practicaltypography.com/charter.html")
+ (synopsis "Charter fonts in OpenType and TrueType formats")
+ (description "Charter was designed by Matthew Carter in 1987 and was
+contributed by Bitstream to the X Consortium in 1992. This package provides
+OpenType, TrueType, and @acronym{WOFF2, Web Open Font Format 2} versions
+converted from the Type 1 originals by Matthew Butterick.")
+ (license
+ (license:non-copyleft
+ "file://Charter license.txt"
+ (string-append
+ "Bitstream contributed the Charter family "
+ "to the X Consortium in 1992. "
+ "The license is also embedded in the font metadata."))))))
+/