summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-01-22 19:42:23 +0800
committerLudovic Courtès <ludo@gnu.org>2022-01-24 10:38:13 +0100
commit23792ae634aaa0acfbc95d4b13052ff59a37b580 (patch)
tree0057c9568854e3622ae47ac1fa1736f88874afb0
parenta00dff3ac113722a709dbe97a727777b3739a5c1 (diff)
downloadguix-patches-23792ae634aaa0acfbc95d4b13052ff59a37b580.tar
guix-patches-23792ae634aaa0acfbc95d4b13052ff59a37b580.tar.gz
gnu: nomad: Fix missing webkit2gtk-4.0 compilation error.
* gnu/package/guile-xyz.scm (nomad)[arguments]<phases>: Add phase 'fix-webkitgtk' to update webkit2gtk-4.0 reference in file 'configure.ac' and 'typelib/Makefile.am'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9a7e7d8ba4..e2cf793acc 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3444,6 +3444,16 @@ perform geometrical transforms on JPEG images.")
(srfi srfi-26))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-webkitgtk
+ (lambda _
+ ;; Adapt to the version we have in Guix.
+ (substitute* "configure.ac"
+ (("webkit2gtk-4\\.0") "webkit2gtk-4.1")
+ (("webkit2gtk-web-extension-4\\.0")
+ "webkit2gtk-web-extension-4.1"))
+
+ (substitute* "typelib/Makefile.am"
+ (("WebKit2-4\\.0") "WebKit2-4.1"))))
(add-before 'check 'start-xorg-server
(lambda* (#:key inputs #:allow-other-keys)
;; The test suite requires a running X server.