summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2022-01-04 01:12:10 +0100
committerLudovic Courtès <ludo@gnu.org>2022-01-24 15:39:16 +0100
commit13b905bf28ec6309043bd61c5a92744b13352021 (patch)
treea089d6119d9bb8ae0f990df761631d8f20039f70
parent6504587168f78720198bdb518d63608af95f312c (diff)
downloadguix-patches-13b905bf28ec6309043bd61c5a92744b13352021.tar
guix-patches-13b905bf28ec6309043bd61c5a92744b13352021.tar.gz
gnu: Add python-tweepy.
* gnu/packages/python-web.scm (python-tweepy): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d2d1389d19..6e4e44c6cf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
@@ -6271,3 +6271,36 @@ purely formal level.
Full documentation may be found at
@uref{https://mwparserfromhell.readthedocs.io, ReadTheDocs}")
(license license:expat)))
+
+(define-public python-tweepy
+ (package
+ (name "python-tweepy")
+ (version "4.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/tweepy/tweepy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jl3j20iqvzqqw5q5ldval5wrc2pdx94zff3b6b87j51yjx3qjhr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "discover" "tests")))))))
+ (propagated-inputs
+ (list python-aiohttp python-requests python-requests-oauthlib))
+ (native-inputs
+ (list python-vcrpy))
+ (home-page "https://www.tweepy.org/")
+ (synopsis "Twitter library for Python")
+ (description "This package provides @code{Tweepy}, an easy-to-use Python
+library for accessing the Twitter API.")
+ (license license:expat)))