summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-11-18 00:14:07 -0500
committerTimothy Sample <samplet@ngyro.com>2021-11-18 10:10:16 -0500
commit08806af6b19a03fb3367fe187fa6502de455a7a2 (patch)
tree963f9ceeb1aa85735b1d1eaa13b5f3797917876b
parent6303c3c4fa4bb8929cd982b78e2ebea51eb98d17 (diff)
downloadguix-patches-08806af6b19a03fb3367fe187fa6502de455a7a2.tar
guix-patches-08806af6b19a03fb3367fe187fa6502de455a7a2.tar.gz
gnu: colord: Enable Vala bindings.
* gnu/packages/gnome.scm (colord)[arguments]: Add "-Dvapi=true" to [native-inputs]: Add vala.
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a47eec2c9d..e1b45388fd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5370,7 +5370,8 @@ output devices.")
(use-modules (srfi srfi-1))
(append '("-Dbash_completion=true"
"-Ddocs=true"
- "-Dman=true")
+ "-Dman=true"
+ "-Dvapi=true")
(fold delete ,flags '("-Dbash_completion=false"
"-Ddocs=false"
"-Dman=false")))))
@@ -5389,7 +5390,8 @@ output devices.")
("docbook-xsl-ns" ,docbook-xsl-ns)
("gtk-doc" ,gtk-doc/stable)
("libxml2" ,libxml2) ;for XML_CATALOG_FILES
- ("libxslt" ,libxslt))
+ ("libxslt" ,libxslt)
+ ("vala" ,vala)) ;for VAPI, needed by simple-scan
(package-native-inputs colord-minimal)))))
(define-public geoclue