summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Lucas <br@ndon.dk>2022-01-23 14:22:54 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-23 18:23:58 +0100
commiteecdb3563d2390fb3d496c15cdfbb73744457211 (patch)
tree2b2d09f9029d5790dcc35fe02a70fda429fc036d
parent312273fcca77b797000e52b2098e91e444f95f78 (diff)
downloadguix-patches-eecdb3563d2390fb3d496c15cdfbb73744457211.tar
guix-patches-eecdb3563d2390fb3d496c15cdfbb73744457211.tar.gz
gnu: Add emacs-cape.
* gnu/packages/emacs-xyz.scm (emacs-cape): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d6e6746c8..304666c8ef 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2902,6 +2902,30 @@ overlay below or above the point. Corfu can be considered the minimalistic
@code{completion-in-region} counterpart of the Vertico minibuffer UI.")
(license license:gpl3+)))
+(define-public emacs-cape
+ (package
+ (name "emacs-cape")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/cape")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0780qymlrg3glyxypizqzwicp5ly5xavxgpmayhx8cxlgp2zlkjh"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/minad/cape")
+ (synopsis "Completion at point extensions for Emacs")
+ (description
+ "Cape provides some Completion At Point Extensions, which can be used in
+combination with Corfu completion UI or the default completion UI. The
+completion backends used by @code{completion-at-point} are so called
+@code{completion-at-point-functions} (Capfs). In principle, the Capfs
+provided by Cape can also be used by Company.")
+ (license license:gpl3+)))
+
(define-public emacs-direnv
(package
(name "emacs-direnv")