summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-17 15:56:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-17 16:15:43 +0100
commit3ce4e265ddefc1f4d5a22ea110e8e6448d55b3a9 (patch)
treeffd98d8da102d793c0c2dcaef412bd12fb1a4324
parent3971dcbf0e39d868a2e360c9b4e6ca2ffcf135e8 (diff)
downloadguix-patches-3ce4e265ddefc1f4d5a22ea110e8e6448d55b3a9.tar
guix-patches-3ce4e265ddefc1f4d5a22ea110e8e6448d55b3a9.tar.gz
gnu: btrfs-progs: Fix bash completions.
This is a follow-up to commit 9a1c4a981bdd7eeca76aaf73a57d6841918821c2. Bash completions must have the same name as the executable. * gnu/packages/linux.scm (btrfs-progs)[arguments]: Rename "btrfs-completion" script to "btrfs".
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bc1c658519..b99c17212a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3245,10 +3245,12 @@ and copy/paste text in the console and in xterm.")
(lambda _ (zero? (system* "make" "static"))))
(add-after 'install 'install-bash-completion
(lambda* (#:key outputs #:allow-other-keys)
- (install-file "btrfs-completion"
- (string-append (assoc-ref outputs "out")
- "/etc/bash_completion.d"))
- #t))
+ (let* ((out (assoc-ref outputs "out"))
+ (bashcomp (string-append out "/etc/bash_completion.d")))
+ (mkdir-p bashcomp)
+ (copy-file "btrfs-completion"
+ (string-append bashcomp "/btrfs"))
+ #t)))
(add-after 'install 'install-static
(let ((staticbin (string-append (assoc-ref %outputs "static")
"/bin")))