summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-20 22:17:07 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-20 22:18:59 +0200
commit29d2f451a663ecf48b9a0709edea2ae2a4124f4d (patch)
treee55a61b7e54855e1acfc59bced6e08735b744002
parent0d871c38766874995c199adc808b97c00394e15d (diff)
downloadguix-patches-29d2f451a663ecf48b9a0709edea2ae2a4124f4d.tar
guix-patches-29d2f451a663ecf48b9a0709edea2ae2a4124f4d.tar.gz
gnu-maintenance: GNOME updater honors 'upstream-name' package property.
* guix/gnu-maintenance.scm (latest-gnome-release)[upstream-name]: New variable. Use it as the first argument to 'latest-ftp-release' and when constructing #:directory. * gnu/packages/gnome.scm (gconf)[properties]: New field. (network-manager)[properties]: New field.
-rw-r--r--gnu/packages/gnome.scm6
-rw-r--r--guix/gnu-maintenance.scm11
2 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9e41f3a65e..dd8305144b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1130,7 +1130,8 @@ use in GNOME applications, built on top of CORBA.")
(synopsis "Store application preferences")
(description "Gconf is a system for storing application preferences. It
is intended for user preferences; not arbitrary data storage.")
- (license license:lgpl2.0+)))
+ (license license:lgpl2.0+)
+ (properties '((upstream-name . "GConf")))))
(define-public gnome-mime-data
@@ -4481,7 +4482,8 @@ devices and connections, attempting to keep active network connectivity when
available. It manages ethernet, WiFi, mobile broadband (WWAN), and PPPoE
devices, and provides VPN integration with a variety of different VPN
services.")
- (license license:gpl2+)))
+ (license license:gpl2+)
+ (properties '((upstream-name . "NetworkManager")))))
(define-public mobile-broadband-provider-info
(package
diff --git a/guix/gnu-maintenance.scm b/guix/gnu-maintenance.scm
index 20f08027da..78392c9a11 100644
--- a/guix/gnu-maintenance.scm
+++ b/guix/gnu-maintenance.scm
@@ -483,13 +483,16 @@ elpa.gnu.org, and all the GNOME packages."
(let-values (((name version) (package-name->name+version file)))
(even-minor-version? (or version name))))
+ (define upstream-name
+ ;; Some packages like "NetworkManager" have camel-case names.
+ (or (assoc-ref (package-properties package) 'upstream-name)
+ (package-name package)))
+
(false-if-ftp-error
- (latest-ftp-release (package-name package)
+ (latest-ftp-release upstream-name
#:server "ftp.gnome.org"
#:directory (string-append "/pub/gnome/sources/"
- (match (package-name package)
- ("gconf" "GConf")
- (x x)))
+ upstream-name)
;; <https://www.gnome.org/gnome-3/source/> explains