summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:17 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:28 +0200
commitda7d72229ab22831cfc7e855cf1b27c6c56143e3 (patch)
treec5b443aa760cb8d3c28e6e01e23a8346f5284e93
parentc1e9ce4c6ede871f073b739116f99c1d4633542e (diff)
downloadguix-patches-da7d72229ab22831cfc7e855cf1b27c6c56143e3.tar
guix-patches-da7d72229ab22831cfc7e855cf1b27c6c56143e3.tar.gz
gnu: Add trytond-commission.
* gnu/packages/tryton.scm (trytond-commission): New variable.
-rw-r--r--gnu/packages/tryton.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 66d755ff3f..3320c3a30b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1572,6 +1572,36 @@ or a specific postal code.")
the weight is greater or equal but smaller than the next line.")
(license license:gpl3+)))
+(define-public trytond-commission
+ (package
+ (name "trytond-commission")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_commission" version))
+ (sha256
+ (base32 "0a5grn6gvvwn0prr5fpgyj4kz283w08a8svmv3b4a4c5pchik3hv"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "commission"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-sale" ,trytond-sale)))
+ (propagated-inputs
+ `(("python-simpleeval" ,python-simpleeval)
+ ("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-account-invoice" ,trytond-account-invoice)
+ ("trytond-account-product" ,trytond-account-product)
+ ("trytond-party" ,trytond-party)
+ ("trytond-product" ,trytond-product)))
+ (home-page "https://docs.tryton.org/projects/modules-commission")
+ (synopsis "Tryton module for commission")
+ (description "The @emph{Commission} Tryton module allows to manageq
+commission for sale's agents. A commission move is created when posting the
+invoice, following the agent's commission plan.")
+ (license license:gpl3+)))
+
(define-public trytond-company
(package
(name "trytond-company")