summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 16:08:00 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commitc3b90c0edb0f04b504adeb96f7dbd35ab8170965 (patch)
tree3eeb8cae8081cee8b729b5b89258f4255ddcacc7
parent775be802a3ec1e39ed55cdee30fe0b448bf4cf97 (diff)
downloadguix-patches-c3b90c0edb0f04b504adeb96f7dbd35ab8170965.tar
guix-patches-c3b90c0edb0f04b504adeb96f7dbd35ab8170965.tar.gz
gnu: Add ghc-hunit
* gnu/packages/haskell.scm (ghc-hunit): New variable.
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4ee8fd9357..cb11a07060 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -412,4 +412,27 @@ data structures. The package provides instances for basic types and a way to
combine hash values.")
(license bsd-3)))
+(define-public ghc-hunit
+ (package
+ (name "ghc-hunit")
+ (version "1.2.5.2")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/HUnit/HUnit-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0hcs6qh8bqhip1kkjjnw7ccgcsmawdz5yvffjj5y8zd2vcsavx8a"))))
+ (build-system haskell-build-system)
+ (home-page "http://hunit.sourceforge.net/")
+ (synopsis "Unit testing framework for Haskell")
+ (description
+ "HUnit is a unit testing framework for Haskell, inspired by the
+JUnit tool for Java.")
+ (license bsd-3)))
+
;;; haskell.scm ends here