summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 17:03:53 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:29 -0600
commitae7135a2d32d777c575c13a89d7cd40600d34dbd (patch)
tree8aa00902076ff3a1e0e41f4b87ab67cd9b222a4e
parent39bbf6131c4a3fea15a279d9a69ed8ad0e308e75 (diff)
downloadguix-patches-ae7135a2d32d777c575c13a89d7cd40600d34dbd.tar
guix-patches-ae7135a2d32d777c575c13a89d7cd40600d34dbd.tar.gz
gnu: Add Task-Weaken.
* gnu/packages/perl.scm (perl-task-weaken): New variable.
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fb5c90ea3f..0338d69834 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1531,6 +1531,29 @@ clock speed.")
"Sys-CPU-" version))
(license (package-license perl))))
+(define-public perl-task-weaken
+ (package
+ (name "perl-task-weaken")
+ (version "1.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ "Task-Weaken-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1i7kd9v8fjsqyhr4rx4a1jv7n5vfjjm1v4agb24pizh0b72p3qk7"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Task-Weaken")
+ (synopsis "Ensure that a platform has weaken support")
+ (description "One recurring problem in modules that use Scalar::Util's
+weaken function is that it is not present in the pure-perl variant. If
+Scalar::Util is not available at all, it will issue a normal dependency on the
+module. However, if Scalar::Util is relatively new ( it is >= 1.19 ) and the
+module does not have weaken, the install will bail out altogether with a long
+error encouraging the user to seek support.")
+ (license (package-license perl))))
+
(define-public perl-test-cleannamespaces
(package
(name "perl-test-cleannamespaces")