summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:22:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:21 +0200
commitadd144a0c4b3636c643829f11baf953352b04b3f (patch)
tree469c6bd4946360e97c07a02549dbec2d5462ca64
parent26cc1eafe77d4f033a498705ffdaf3aea3f6fc10 (diff)
downloadguix-patches-add144a0c4b3636c643829f11baf953352b04b3f.tar
guix-patches-add144a0c4b3636c643829f11baf953352b04b3f.tar.gz
gnu: Add r-paws-common.
* gnu/packages/cran.scm (r-paws-common): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index eb00a6f3fb..68861bf571 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30592,3 +30592,32 @@ of known occurrences of a species.")
runs full species distribution modelling workflows and returns output that is
fully reproducible.")
(license license:bsd-3)))
+
+(define-public r-paws-common
+ (package
+ (name "r-paws-common")
+ (version "0.3.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "paws.common" version))
+ (sha256
+ (base32
+ "1khq1rv0yij4l0vi2x6hslnzpsd6m5n6nipfac7g3na9ah93h8i9"))))
+ (properties `((upstream-name . "paws.common")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-base64enc" ,r-base64enc)
+ ("r-digest" ,r-digest)
+ ("r-httr" ,r-httr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-xml2" ,r-xml2)))
+ (home-page "https://cran.r-project.org/package=paws.common")
+ (synopsis "Paws low-level Amazon Web Services API")
+ (description
+ "This package provides functions for making low-level API requests to
+Amazon Web Services. The functions handle building, signing, and sending
+requests, and receiving responses. They are designed to help build
+higher-level interfaces to individual services, such as Simple Storage
+Service (S3).")
+ (license license:asl2.0)))