summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 19:15:21 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:13 +0200
commit9ce031c57ff856712032658aa6a1aa418d7a37f6 (patch)
treefee9327fe7aee8e6f5da7057a4a0c1f263c974f4
parentabfed253e69c2ef2a7a1b728eee28b482e889c21 (diff)
downloadguix-patches-9ce031c57ff856712032658aa6a1aa418d7a37f6.tar
guix-patches-9ce031c57ff856712032658aa6a1aa418d7a37f6.tar.gz
gnu: Add ghc-network-uri.
* gnu/packages/haskell.scm (ghc-network-uri): New variable.
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0bf927f691..8240b461ae 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -807,4 +807,35 @@ mutable and immutable), with a powerful loop optimisation framework.")
"This package provides a low-level networking interface.")
(license bsd-3)))
+(define-public ghc-network-uri
+ (package
+ (name "ghc-network-uri")
+ (version "2.6.0.1")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/network-uri/network-uri-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "09ymamb128jgqghpda4nixncr73all8qc6q53976aricm6a27p37"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-network" ,ghc-network)))
+ (arguments
+ `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ (propagated-inputs
+ `(("ghc-parsec" ,ghc-parsec)))
+ (home-page
+ "https://github.com/haskell/network-uri")
+ (synopsis "Labrary for URI manipulation")
+ (description "This package provides an URI manipulation inteface. In
+'network-2.6' the 'Network.URI' module was split off from the 'network'
+package into this package.")
+ (license bsd-3)))
+
;;; haskell.scm ends here