summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:15 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:27 +0200
commit9987be26929eff44c46794555242fdf665e4f819 (patch)
treed08b06af37387f5ac6a822b88ce186dfcfc1dad1
parent9acb1a6cae500ebe3526872f9a6c26bcd015ab95 (diff)
downloadguix-patches-9987be26929eff44c46794555242fdf665e4f819.tar
guix-patches-9987be26929eff44c46794555242fdf665e4f819.tar.gz
gnu: Add trytond-bank.
* gnu/packages/tryton.scm (trytond-bank): New variable.
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index cb81695412..addaea9fdb 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1433,6 +1433,30 @@ used in the list of authentications in the session section of the
configuration file.")
(license license:gpl3+)))
+(define-public trytond-bank
+ (package
+ (name "trytond-bank")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_bank" version))
+ (sha256
+ (base32 "0qwgp2s88n4hcqqxg1g34lmmvq5spdlkm978gzn6s96kmmzang0c"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "bank"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("python-stdnum" ,python-stdnum)
+ ("trytond" ,trytond)
+ ("trytond-currency" ,trytond-currency)
+ ("trytond-party" ,trytond-party)))
+ (home-page "https://docs.tryton.org/projects/modules-bank")
+ (synopsis "Tryton module with banks")
+ (description "The @emph{Bank} Tryton module defines the concept of bank
+and account.")
+ (license license:gpl3+)))
+
(define-public trytond-company
(package
(name "trytond-company")