summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:16 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:28 +0200
commit755993bf931130f4adcdbc67aab4ba627ef02691 (patch)
treeb8e567268c15bfb054af67092cde4a8b06a47c58
parentd727ff9d292077781454a3fd8a8766c7990b7b9f (diff)
downloadguix-patches-755993bf931130f4adcdbc67aab4ba627ef02691.tar
guix-patches-755993bf931130f4adcdbc67aab4ba627ef02691.tar.gz
gnu: Add trytond-carrier-subdivision.
* gnu/packages/tryton.scm (trytond-carrier-subdivision): New variable.
-rw-r--r--gnu/packages/tryton.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4472b18305..2e6e2c1036 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1507,6 +1507,41 @@ of carrier.")
method \"on percentage\" on carrier.")
(license license:gpl3+)))
+(define-public trytond-carrier-subdivision
+ (package
+ (name "trytond-carrier-subdivision")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_carrier_subdivision" version))
+ (sha256
+ (base32 "1mmbz541yywdgm16ij2xfvm50xad24plmqdb739ssg6jj0skmji4"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "carrier_subdivision"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-sale-shipment-cost" ,trytond-sale-shipment-cost)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-carrier" ,trytond-carrier)))
+ (home-page "https://docs.tryton.org/projects/modules-carrier-subdivision")
+ (synopsis "Tryton module that allows carriers selection to be restricted
+by subdivision")
+ (description "The @emph{Carrier Subdivision} Tryton module extends the
+carrier selection pattern with
+
+@itemize
+@item the warehouse Subdivision,
+@item the customer Subdivision,
+@item a regular expression to match against warehouse postal code and
+@item A regular expression to match against customer postal code.
+@end itemize
+
+These can be used to restrict the usage of a carrier to a specific subdivision
+or a specific postal code.")
+ (license license:gpl3+)))
+
(define-public trytond-company
(package
(name "trytond-company")