summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-03-05 08:38:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-03-09 09:05:00 +0100
commit412726ee4ad459cf5fcd7e122fa30de668dcc142 (patch)
tree43cb990ac61bfd4ab880b9a135ed888c64179b57
parent0c36a681c8fe7248924a15379ab3b1cc92ecdcd1 (diff)
downloadguix-patches-412726ee4ad459cf5fcd7e122fa30de668dcc142.tar
guix-patches-412726ee4ad459cf5fcd7e122fa30de668dcc142.tar.gz
gnu: Add gEDA/gaf.
* gnu/packages/engineering.scm (geda-gaf): New variable.
-rw-r--r--gnu/packages/engineering.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c3f9f44f8b..b29c6bc9f4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -20,13 +20,19 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages boost)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages guile)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
#:use-module (srfi srfi-1))
@@ -84,3 +90,48 @@
"LibreCAD is a 2D Computer-aided design (CAD) application for creating
plans and designs.")
(license license:gpl2)))
+
+(define-public geda-gaf
+ (package
+ (name "geda-gaf")
+ (version "1.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://ftp.geda-project.org/geda-gaf/stable/v"
+ (version-major+minor version) "/"
+ version "/geda-gaf-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08dpa506xk4gjbbi8vnxcb640wq4ihlgmhzlssl52nhvxwx7gx5v"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ ;; tests require a writable HOME
+ (alist-cons-before
+ 'check 'set-home
+ (lambda _
+ (setenv "HOME" (getenv "TMPDIR")))
+ %standard-phases)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk" ,gtk+-2)
+ ("guile" ,guile-2.0)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("shared-mime-info" ,shared-mime-info)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("perl" ,perl))) ; for tests
+ (home-page "http://geda-project.org/")
+ (synopsis "Schematic capture, netlister, symbols, symbol checker, and utils")
+ (description
+ "gaf stands for “gschem and friends”. It is a subset of the entire tool
+suite grouped together under the gEDA name. gEDA/gaf is a collection of tools
+which currently includes: gschem, a schematic capture program; gnetlist, a
+netlist generation program; gsymcheck, a syntax checker for schematic symbols;
+gattrib, a spreadsheet programm that manipulates the properties of symbols of
+a schematic; libgeda, libraries for gschem gnetlist and gsymcheck; gsch2pcb, a
+tool to forward annotation from your schematic to layout using PCB; some minor
+utilities.")
+ (license license:gpl2+)))
+