summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-10-23 02:03:41 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-11-05 18:44:06 +0100
commit1ce9759407f000a1333ef97a70b347b9cd4b8a4c (patch)
tree143bf2d21ce3c390e2cda83cb52b9ada919f1e83
parent336c9f0a81c9bc0ed0a2d3e0d050a677806c07c0 (diff)
downloadguix-patches-1ce9759407f000a1333ef97a70b347b9cd4b8a4c.tar
guix-patches-1ce9759407f000a1333ef97a70b347b9cd4b8a4c.tar.gz
gnu: Add go-github-com-hjson-hjson-go.
* gnu/packages/golang.scm (go-github-com-hjson-hjson-go): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ba75308a4a..d4de1f5c45 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5955,3 +5955,27 @@ tests.")
(synopsis "Golang syslog wrapper, cross-compile friendly")
(description "This package is a very simple wrapper around log/syslog")
(license license:expat)))
+
+(define-public go-github-com-hjson-hjson-go
+ (package
+ (name "go-github-com-hjson-hjson-go")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hjson/hjson-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dfdiahimg6z9idg8jiqxwnlwjnmasbjccx8gnag49cz4yfqskaz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hjson/hjson-go"))
+ (home-page "https://hjson.org/")
+ (synopsis "Human JSON implementation for Go")
+ (description "Hjson is a syntax extension to JSON. It is intended to be
+used like a user interface for humans, to read and edit before passing the
+JSON data to the machine.")
+ (license license:expat)))