summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazev@posteo.org>2022-01-17 15:16:34 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-22 13:10:16 +0100
commit19f1054617251c23cd82d0cfaebcabe1f8e82d82 (patch)
tree8476f58369f37b91a23e1bfbfc50217d3aefc510
parent9d059d0332eb3cda930cc4a48a57610b8421ef55 (diff)
downloadguix-patches-19f1054617251c23cd82d0cfaebcabe1f8e82d82.tar
guix-patches-19f1054617251c23cd82d0cfaebcabe1f8e82d82.tar.gz
gnu: Add rust-open-2.
* gnu/packages/crates-io.scm (rust-open-2): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c2a64c82ec..422a7fe61a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37788,6 +37788,30 @@ contents.")
(base32
"02942l2gc7w5r4js7i9063x99szic5mzzk1055j83v4diqpbpxck"))))))
+(define-public rust-open-2
+ (package
+ (name "rust-open")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "open" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1dq9c6dgq7iv5kvqfk8gvkfq34j5pdinfcs1hbdd4x6i62vf8vhp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-pathdiff" ,rust-pathdiff-0.2)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/Byron/open-rs")
+ (synopsis "Open a path or URL using the program configured on the system")
+ (description
+ "Use this library to open a path or URL using the program configured on
+the system.")
+ (license license:expat)))
+
(define-public rust-open-1
(package
(name "rust-open")