summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2015-12-07 16:19:35 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-02-02 09:23:00 -0500
commitf5bcec6e7d1402a0074499d5a81a4f3334405cb0 (patch)
tree47e7030b7ca1c2cc40e972d809efc29ffb9c121c
parent2b2f2fc1797c3a5d8398307205365667ce5941db (diff)
downloadguix-patches-f5bcec6e7d1402a0074499d5a81a4f3334405cb0.tar
guix-patches-f5bcec6e7d1402a0074499d5a81a4f3334405cb0.tar.gz
gnu: Add python-rsa.
* gnu/packages/python.scm (python-rsa, python2-rsa): New variables.
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 247d3c5b5e..3db26acff2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7273,3 +7273,29 @@ text.")
(define-public python2-colorama
(package-with-python2 python-colorama))
+
+(define-public python-rsa
+ (package
+ (name "python-rsa")
+ (version "3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rsa" version))
+ (sha256
+ (base32
+ "0xwp929g7lvb1sghxfpqlxvgg96qcwqdbhh27sjplx30n3xp3wrh"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-pyasn1" ,python-pyasn1)
+ ("python-setuptools" ,python-setuptools)))
+ (synopsis "Pure-Python RSA implementation")
+ (description "Python-RSA is a pure-Python RSA implementation. It supports
+encryption and decryption, signing and verifying signatures, and key
+generation according to PKCS#1 version 1.5. It can be used as a Python
+library as well as on the command line.")
+ (home-page "http://stuvel.eu/rsa")
+ (license asl2.0)))
+
+(define-public python2-rsa
+ (package-with-python2 python-rsa))