summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-02-04 11:57:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-04 11:57:14 +0100
commitd9b0216b6f6d8a7db4ae130c212dc28eb3e646a2 (patch)
treed0aeaa684f6d3a54aa68bc4e6ce0f517e35234e7
parent05b4b3ea05b2a9e0c769fe3418c54a2819447a25 (diff)
downloadguix-patches-d9b0216b6f6d8a7db4ae130c212dc28eb3e646a2.tar
guix-patches-d9b0216b6f6d8a7db4ae130c212dc28eb3e646a2.tar.gz
gnu: python-send2trash: Remove duplicates.
* gnu/packages/python-xyz.scm (python-send2trash, python2-send2trash): Remove duplicates. [source]: Fetch from git.
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 7 insertions, 28 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae3e005be2..812377e6ad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4505,28 +4505,6 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(define-public python2-ipykernel
(package-with-python2 python-ipykernel))
-(define-public python-send2trash
- (package
- (name "python-send2trash")
- (version "1.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "send2trash" version))
- (sha256
- (base32
- "1ci8vcwjmjlp11ljj1ckrfmml9fkq1mclx2gr53y4zvhgp01q030"))))
- (build-system python-build-system)
- (home-page "https://github.com/hsoft/send2trash")
- (synopsis "Send files to trash")
- (description
- "This package provides a cross-platform mechanism to send files to the
-trash.")
- (license license:bsd-3)))
-
-(define-public python2-send2trash
- (package-with-python2 python-send2trash))
-
;; This is the latest release of the LTS version of ipython with support for
;; Python 2.7 and Python 3.x. Later non-LTS versions starting from 6.0 have
;; dropped support for Python 2.7. We may want to rename this package.
@@ -13215,16 +13193,17 @@ and works only with Python 2 and NumPy < 1.9.")
(define-public python-send2trash
(package
(name "python-send2trash")
- (version "1.4.2")
+ (version "1.5.0")
(source
- (origin (method url-fetch)
+ (origin (method git-fetch)
;; Source tarball on PyPI doesn't include tests.
- (uri (string-append "https://github.com/hsoft/send2trash/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/hsoft/send2trash.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0ffyhwjyx61slkdy38iwjc4gmj7fj9gs2q58f075gwvq630pzm9z"))))
+ "1c76zldhw2ay7q7r00nnzcampjz9lkqfcbzqpm0iqp5i6bmmv30v"))))
(build-system python-build-system)
(arguments
'(#:phases