summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2015-12-07 16:20:07 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-02-02 09:23:00 -0500
commitc0aacfa5b903f1a0b9038aee7fe8f7f120f9d734 (patch)
tree494f1bbfbc7382f3c06ceb20e5331a3d6a0c21b0
parentf5bcec6e7d1402a0074499d5a81a4f3334405cb0 (diff)
downloadguix-patches-c0aacfa5b903f1a0b9038aee7fe8f7f120f9d734.tar
guix-patches-c0aacfa5b903f1a0b9038aee7fe8f7f120f9d734.tar.gz
gnu: Add python-pluggy.
* gnu/packages/python.scm (python-pluggy): New variable.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3db26acff2..52950141f2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7299,3 +7299,26 @@ library as well as on the command line.")
(define-public python2-rsa
(package-with-python2 python-rsa))
+
+(define-public python-pluggy
+ (package
+ (name "python-pluggy")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pluggy" version))
+ (sha256
+ (base32
+ "18qfzfm40bgx672lkg8q9x5hdh76n7vax99aank7vh2nw21wg70m"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (synopsis "Plugin and hook calling mechanism for Python")
+ (description "Pluggy is an extraction of the plugin manager as used by
+Pytest but stripped of Pytest specific details.")
+ (home-page "https://pypi.python.org/pypi/pluggy")
+ (license license:expat)))
+
+(define-public python2-pluggy
+ (package-with-python2 python-pluggy))