summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2015-12-07 16:22:00 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-02-02 09:23:00 -0500
commitba9da248a6e23e2203a5e412b3688c0c648e68da (patch)
tree5ada9bdbff2551477f73cdf0be9a5f1380cd09ba
parenta4af21ca6dfc362e15824674c5652bdf1c922ffd (diff)
downloadguix-patches-ba9da248a6e23e2203a5e412b3688c0c648e68da.tar
guix-patches-ba9da248a6e23e2203a5e412b3688c0c648e68da.tar.gz
gnu: Add python-jmespath.
* gnu/packages/python.scm (python-jmespath): New variable.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6be651195d..5e046a19bf 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7356,3 +7356,27 @@ servers.")
(define-public python2-tox
(package-with-python2 python-tox))
+
+(define-public python-jmespath
+ (package
+ (name "python-jmespath")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jmespath" version))
+ (sha256
+ (base32
+ "0g9xvl69y7nr3w7ag4fsp6sm4fqf6vrqjw7504x2hzrrsh3ampq8"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (synopsis "JSON Matching Expressions")
+ (description "JMESPath (pronounced “james path”) is a Python library that
+allows one to declaratively specify how to extract elements from a JSON
+document.")
+ (home-page "https://github.com/jmespath/jmespath.py")
+ (license license:expat)))
+
+(define-public python2-jmespath
+ (package-with-python2 python-jmespath))