summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2015-12-07 16:22:20 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-02-02 09:23:00 -0500
commit935fcd5cf625046f707f18f2992717e63c7aa412 (patch)
tree15bf15e6c1e483a6806fc72f3d127e4ffa527936
parentba9da248a6e23e2203a5e412b3688c0c648e68da (diff)
downloadguix-patches-935fcd5cf625046f707f18f2992717e63c7aa412.tar
guix-patches-935fcd5cf625046f707f18f2992717e63c7aa412.tar.gz
gnu: Add python-botocore.
* gnu/packages/python.scm (python-botocore): New variable.
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5e046a19bf..463b9baa70 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7380,3 +7380,33 @@ document.")
(define-public python2-jmespath
(package-with-python2 python-jmespath))
+
+(define-public python-botocore
+ (package
+ (name "python-botocore")
+ (version "1.3.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "botocore" version))
+ (sha256
+ (base32
+ "08vpvdixx1c1lfv6vzjig68bpiir7wfyhzf49ysxgvhbprg5ra0w"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-dateutil" ,python-dateutil-2)
+ ("python-docutils" ,python-docutils)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)
+ ("python-setuptools" ,python-setuptools)
+ ("python-tox" ,python-tox)
+ ("python-wheel" ,python-wheel)
+ ("python-jmespath" ,python-jmespath)))
+ (home-page "https://github.com/boto/botocore")
+ (synopsis "Low-level interface to AWS")
+ (description "Botocore is a Python library that provides a low-level
+interface to the Amazon Web Services (AWS) API.")
+ (license asl2.0)))
+
+(define-public python2-botocore
+ (package-with-python2 python-botocore))