summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-02-10 17:56:51 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:04:14 +0100
commit82d7d4e1c81744f49f3b2168774437532755b32d (patch)
treebc9064651f95754c3d21a05908b7a78aae19ca5b
parent96f31935ec25e9c942b7855c4a7078e7cfe32d6b (diff)
downloadguix-patches-82d7d4e1c81744f49f3b2168774437532755b32d.tar
guix-patches-82d7d4e1c81744f49f3b2168774437532755b32d.tar.gz
gnu: Add java-xpp3.
gnu/packages/xml.scm (java-xpp3): New variable.
-rw-r--r--gnu/packages/xml.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 2e2b714cb5..e65ea53f3e 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1685,3 +1685,37 @@ that strives for correctness and simplicity.")
(description "Xsdlib contains an implementation of sun.com.msv, an XML
validator.")
(license license:bsd-2)))
+
+(define-public java-xpp3
+ (package
+ (name "java-xpp3")
+ (version "1.1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.extreme.indiana.edu/dist/"
+ "java-repository/xpp3/distributions/xpp3-"
+ version "_src.tgz"))
+ (sha256
+ (base32
+ "1b99zrhyij5qwyhilyjdl1ykxvhk902vsvflh6gx4fir8hfvdl5p"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin ;; Delete bundled jar archives.
+ (for-each delete-file (find-files "." ".*\\.jar"))
+ #t))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f; no tests
+ #:build-target "jar"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install (install-jars "build")))))
+ (home-page "http://www.extreme.indiana.edu/xgws/xsoap/xpp/")
+ (synopsis "Streaming pull XML parser")
+ (description "Xml Pull Parser (in short XPP) is a streaming pull XML
+parser and should be used when there is a need to process quickly and
+efficiently all input elements (for example in SOAP processors). This
+package is a stable XmlPull parsing engine that is based on ideas from XPP
+and in particular XPP2 but completely revised and rewritten to take the best
+advantage of JIT JVMs.")
+ (license (license:non-copyleft "file://LICENSE.txt"))))