summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-02-10 18:28:17 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:04:23 +0100
commit3058d8ec560ff37a2a4af678e6776546f5b083c2 (patch)
treeecd88aefcc9f5dd1294ce8dcd6344464140121f3
parentbe0524f472f4e6d65b0da0fe15ba9e999c21876f (diff)
downloadguix-patches-3058d8ec560ff37a2a4af678e6776546f5b083c2.tar
guix-patches-3058d8ec560ff37a2a4af678e6776546f5b083c2.tar.gz
gnu: Add java-kxml2.
* gnu/packages/xml.scm (java-kxml2): New variable.
-rw-r--r--gnu/packages/xml.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 42e5ef421c..ce7eb4bf9b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1831,3 +1831,39 @@ with DOM, SAX, XPath, and XSLT. It can parse large XML documents with very
low memory footprint.")
;; some BSD-like 5-clause license
(license (license:non-copyleft "file://LICENSE"))))
+
+(define-public java-kxml2
+ (package
+ (name "java-kxml2")
+ (version "2.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/stefanhaustein/kxml2/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "17kh04qf3vll1xx6sv06xlazw2hxa8qdmzyday9r6z2191jlj74w"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "kxml2.jar"
+ #:source-dir "src/main/java"
+ #:test-include (list "TestWb.java")
+ ;; Test failure: it was expected to get an XML entity but got the
+ ;; equivalent Unicode character instead.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "src/main/resources" "build/classes"))))))
+ (inputs
+ `(("java-xpp3" ,java-xpp3)))
+ (native-inputs
+ `(("java-junit" ,java-junit)))
+ (home-page "http://kxml.org")
+ (synopsis "XML pull parser")
+ (description "kXML is a small XML pull parser, specially designed for
+constrained environments such as Applets, Personal Java or devices compliant
+with the Mobile Information Device Profile (MIDP).")
+ (license license:expat)))