summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-21 11:31:32 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:22:59 +0100
commitee6e69a554073b0b55ffbbd9ad2e451ae234c5f2 (patch)
tree7955698a0908475b213d8296f27340bde19e8dd2
parente22957fc153fe32a0c11f238e7ed6233902bd40a (diff)
downloadguix-patches-ee6e69a554073b0b55ffbbd9ad2e451ae234c5f2.tar
guix-patches-ee6e69a554073b0b55ffbbd9ad2e451ae234c5f2.tar.gz
gnu: python-psycopg2: Update to 2.9.3.
* gnu/packages/databases.scm (python-psycopg2): Update to 2.9.3. [home-page]: Follow redirect to <https://www.psycopg.org>.
-rw-r--r--gnu/packages/databases.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ff81b24518..2dec250a5e 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3406,21 +3406,21 @@ designed to be easy and intuitive to use.")
(define-public python-psycopg2
(package
(name "python-psycopg2")
- (version "2.9.2")
+ (version "2.9.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "psycopg2" version))
(sha256
- (base32 "1smvvs1ngqy0ymlp1d7f85j09j9v0z5dq14f1qky0j0qi7xajkd8"))))
+ (base32 "1099as8ind9kpz30rmqzc3nir668fmpkxwayrj2sjka3ycdiv14f"))))
(build-system python-build-system)
(arguments
;; Tests would require a postgresql database "psycopg2_test"
;; and a running postgresql database management service.
- `(#:tests? #f)) ; TODO re-enable after providing a test-db.
+ '(#:tests? #f)) ; TODO re-enable after providing a test-db.
(inputs
(list postgresql)) ; libpq
- (home-page "http://initd.org/psycopg/")
+ (home-page "https://www.psycopg.org/")
(synopsis "Python PostgreSQL adapter")
(description
"psycopg2 is a thread-safe PostgreSQL adapter that implements DB-API