summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart via Guix-patches via <guix-patches@gnu.org>2022-01-22 02:23:30 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2022-01-22 12:20:46 +0300
commite22957fc153fe32a0c11f238e7ed6233902bd40a (patch)
treec593f4efca2c7b54f3ddd2b735bf89de7b730493
parentd0744d8650b9b5358f19b94a1f886f029f3d3f78 (diff)
downloadguix-patches-e22957fc153fe32a0c11f238e7ed6233902bd40a.tar
guix-patches-e22957fc153fe32a0c11f238e7ed6233902bd40a.tar.gz
gnu: Add nbss-upload.
* gnu/packages/python-xyz.scm (nbss-upload): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 828e376db9..113e3b8077 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28663,6 +28663,28 @@ it supports reStructuredText, Markdown, IPython (Jupyter) Notebooks and HTML,
and has plugins for many other formats.")
(license license:expat)))
+(define-public nbss-upload
+ (package
+ (name "nbss-upload")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nbss-upload" version))
+ (sha256
+ (base32 "0jhyfm7w2ssknmh9789fmpnf79xr7sxbdcjwak6hfha6qparvk38"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-requests))
+ (arguments
+ `(#:tests? #f)) ;no tests
+ (home-page "https://github.com/notebook-sharing-space/nbss-upload")
+ (synopsis "Upload notebooks to a notebooksharing.space instance")
+ (description
+"Upload notebooks as @code{.ipynb}, @code{.rmd}, and @code{.html} to a
+notebooksharing.space instance.")
+ (license license:bsd-3)))
+
(define-public python-reedsolo
(package
(name "python-reedsolo")